Announcement

Collapse
No announcement yet.

Floppy write protect... ideeen?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Floppy write protect... ideeen?

    Hallo!

    Mijn Amiga 1200 leek helemaal mooi te werken, tot ik iets naar een floppy wilde kopiëren. Helaas: "write protect enabled"... terwijl dat dus niet zo is. Lezen van floppies gaat prima zowel met interne als externe drive. Alleen schrijven, formatteren, AmigaTestKit v1.5 write test gaan niet. Wat ik heb geprobeerd:
    - Alle uitbreidingen loskoppelen
    - HDD loskoppelen
    - Interne floppydrive loskoppelen
    - Externe floppydrive proberen
    - Andere externe floppydrive proberen
    - Externe floppydrives op andere Amiga proberen
    - Continuiteit en weerstand van betreffende traces op het moederbord (voor signaal WPRO) doorgemeten
    - Ik heb geen scope dus hier houdt het voor mij op...

    Nu is het dus waarschijnlijk een defecte CIA chip, dat wordt pogingen doen een vervanger te zoeken en die erop te solderen.

    Maar ik hoop eigenlijk dat iemand misschien toch nog andere ideeën heeft... ik vind het altijd zo maf als van een chip een klein stukje het niet doet, en de rest wel...

    Elk advies is welkom!
    Last edited by VosCoBoss; 26-03-2020, 16:55.
    Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

    #2
    Ik neem even aan dat je het over een A500 hebt, dan kan je even beide CIA chips omdraaien. Ze zijn namelijk identiek.
    Je zal dan andere storingen krijgen, maar diskdrive zou het dan weer moeten doen.

    Comment


      #3
      Originally posted by PRS View Post
      Ik neem even aan dat je het over een A500 hebt, dan kan je even beide CIA chips omdraaien. Ze zijn namelijk identiek.
      Je zal dan andere storingen krijgen, maar diskdrive zou het dan weer moeten doen.
      Nee helaas, ik heb het er nu even bijgezet dat het om een A1200 gaat. De truc met het omwisselen bij de A500 gaat bij de A1200 jammer genoeg niet zo makkelijk...
      Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

      Comment


        #4
        Heb je de externe floppy op de interne poort aangesloten of rechstreeks naar een externe floppy proberen te schrijven? Dat was me niet helemaal duidelijk. Als je ook niet naar een externe floppy kan schrijven dan ligt het zeer waarschijnlijk aan de CIA of draadbreuk oid. Corrosie kan ook de boosdoener zijn in die hoek. maar dan moet je alle spoortjes met een loep goed onderzoeken

        Comment


          #5
          Originally posted by Stronk View Post
          Heb je de externe floppy op de interne poort aangesloten of rechstreeks naar een externe floppy proberen te schrijven? Dat was me niet helemaal duidelijk. Als je ook niet naar een externe floppy kan schrijven dan ligt het zeer waarschijnlijk aan de CIA of draadbreuk oid. Corrosie kan ook de boosdoener zijn in die hoek. maar dan moet je alle spoortjes met een loep goed onderzoeken
          Bedankt voor het meedenken! De externe floppy was op de floppy poort. Het is inderdaad waarschijnlijk de CIA... draadbreuk kan bijna niet, ik heb relevante traces al doorgemeten en die zijn goed. Het enige andere wat nog zou kunnen is dat iets anders het signaal altijd hoog of laag houdt (geen idee of die hoog of laag moet zijn voor write protect), misschien door een sluitinkje ergens... dat ga ik nog verder proberen te achterhalen.

          Of misschien kent iemand een software-trucje om write-protect te omzeilen? Zo vaak hoef ik geen floppy te schrijven en verder werkt de Amiga goed... CIA chip desolderen en solderen is wel erg aan de bovenkant van mijn skillset namelijk...
          Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

          Comment


            #6
            Ik heb nu even een vergelijking gedaan tussen de rev 1d.1 (die werkt) en de rev 2b (met het probleem)... op de rev 1d.1 heb ik 2k Ohm weerstand tussen ground en de WPRO pin op de CIA. Op de rev 2b 0 Ohm... dat klopt niet. Moet nu dus verder zoeken of dit de CIA is, of iets anders wat die pin naar 0 trekt.
            Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

            Comment


              #7
              Hier vind je het hele moederbord (als je dat nog niet wist) en waar de spoortjes naartoe gaan. kan je nog eens goed meten

              Comment


                #8
                Onorthodoxe oplossing: betreffende pin van de CIA losgesoldeerd... nu denkt de Amiga dat alle disks niet write-protected zijn. Het echte probleem heb ik nog niet boven water, hier mis ik toch even wat electronica-kennis. Vermoedelijk een elco (C588). Maar ik weet het niet zeker, en durf daar nog niet aan te solderen. En ik heb geen SMD elco's...
                Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

                Comment


                  #9
                  Tja. Ik heb het probleem gevonden. Achteraf bezien natuurlijk het eerste wat ik had moeten controleren. Of nog beter: had moeten voorkomen. De betreffende trace loopt namelijk vlak langs de GND-pin van een elco. Laat ik nou met recappen dus toch een microscopische beschadiging hebben gemaakt op die trace en vervolgens daar een mini-soldeerbruggetje te hebben gemaakt. Logisch dus dat de lijn altijd laag was. Maar nooit opgemerkt want ja, hoe vaak schrijf je tegenwoordig nou naar een floppy?

                  Aan de ene kant denk ik nu: laat het dan ook door een professional doen.

                  Aan de andere kant denk ik nu: weer wat geleerd!

                  Anyway, lessons learned:
                  - Nog voorzichtiger werken bij recappen en solderen in het algemeen
                  - Beter controleren na soldeerwerk te hebben gedaan
                  - Beter bedenken wat je hebt gedaan voordat het probleem zich voor het eerst voordeed
                  - Bij troubleshooten direct een schemaatje tekenen en daarna als eerste de traces nalopen
                  Amiga 1200 rev 2b, transparante A1200.net case, ACA1233n/55, 120 gb Intel SSD

                  Comment


                    #10
                    Originally posted by VosCoBoss View Post
                    Tja. Ik heb het probleem gevonden. Achteraf bezien natuurlijk het eerste wat ik had moeten controleren. Of nog beter: had moeten voorkomen. De betreffende trace loopt namelijk vlak langs de GND-pin van een elco. Laat ik nou met recappen dus toch een microscopische beschadiging hebben gemaakt op die trace en vervolgens daar een mini-soldeerbruggetje te hebben gemaakt. Logisch dus dat de lijn altijd laag was. Maar nooit opgemerkt want ja, hoe vaak schrijf je tegenwoordig nou naar een floppy?

                    Aan de ene kant denk ik nu: laat het dan ook door een professional doen.

                    Aan de andere kant denk ik nu: weer wat geleerd!

                    Anyway, lessons learned:
                    - Nog voorzichtiger werken bij recappen en solderen in het algemeen
                    - Beter controleren na soldeerwerk te hebben gedaan
                    - Beter bedenken wat je hebt gedaan voordat het probleem zich voor het eerst voordeed
                    - Bij troubleshooten direct een schemaatje tekenen en daarna als eerste de traces nalopen
                    Met recappen moet je voorzichtig te werk gaan en weten wat je doet. Heb veel respect wat TSB doet en vind het prachtig dat je goed ermee bezig bent. Zelf doe ik het niet meer wil nu meer ervan genieten vandaar al die AMIGA en C64 projecten. Ben steeds bezig naar het zoeken naar onderdelen en zo goed mogelijk een mooie combinatie ervan te verwezenlijken. Natuurlijk kom je steeds obstakels tegen hoe groot en hoe klein het is. Je blijft ermee bezig en je leert er veel van hoe alles werkt qua hardware en software.

                    Heb de C64G zo goed mogelijk opgeknapt en werkt perfect de 250469 Rev4 moederbord.

                    Click image for larger version  Name:	C43F8310-E521-4A94-8E39-CA162B20034A.jpeg Views:	0 Size:	472.9 KB ID:	23797
                    A1200 BLACK Rev1D.4 RECAP / Indivision AGA MK3 (hoping) / ACA1260 (hoping) / 1ste Project
                    A1200 CD32 Rev1D.4 RECAP / Indivision AGA MK2CR / Blizzard 1230 IV / 2de Project
                    A1200 GHOST Rev2B RECAP / FastATA A1200 MK-V (wanting) / Blizzard 1260 (wanting) / 3de Project
                    A500 BLACK Rev6A / ACE2 / Indivision ECS V1 8373R3PD / ACA500Plus V1 / ACA1233n-55 IDE Speeder RTC

                    A1200 BLACK / CD32 / GHOST / WB 3.1.4.1 - BestWB 1.3 - FFS 4K 16GB CF
                    A500 BLACK / WB 3.1.4.1 - BestWB 1.3 - FFS 4K 16GB CF

                    Comment

                    Working...
                    X